IMUNES: Unterschied zwischen den Versionen

Aus C3D2
Wechseln zu: Navigation, Suche
Zeile 97: Zeile 97:
  
 
[[Datei:C3d2_imunes_example.jpg]]
 
[[Datei:C3d2_imunes_example.jpg]]
 +
 +
== Hinweise ==
 +
 +
vlan scheint derzeit nicht zu gehen, die freenas bridge scheint es wohl nicht durchzureichen (müsste man mal genauer gebuggen)

Version vom 11. Oktober 2015, 03:17 Uhr

IMUNES

IMUNES - IP network emulator / simulator Quelle: imunes.net

Open-Source Routing and Network Simulation IMUNES for FreeBSD

Quelle: imunes.net/download Quelle: brianlinkletter.com

Umgebung

Auf freenas/storage läuft vHOST (VirtualBox Jail) die die VM: IMUNES-FreeBSD-10.1-RELEASE_20150506 ausführt

  • IP: .99 (port VNC 3389)

IMUNES

  • IP: .98 (port SSH 22 mit X Forwarding)

IMUNES HOST Interfaces

Virtualbox gibt 4x das epair als Paravirtualized Network Adapter (virtio-net) frei, über eine Bridge und keine Filterung von MAC Adressen! (Vollzugriff)

vtnet0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=6c03bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
	ether 00:00:00:00:00:00
	inet .98 netmask 0xffffff00 broadcast .255 
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet 10Gbase-T <full-duplex>
	status: active
vtnet1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=6c03bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
	ether 00:00:00:00:00:00
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet 10Gbase-T <full-duplex>
	status: active
vtnet2: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=6c03bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
	ether 00:00:00:00:00:00
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet 10Gbase-T <full-duplex>
	status: active
vtnet3: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=6c03bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
	ether 00:00:00:00:00:00
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet 10Gbase-T <full-duplex>
	status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

vtnet0 dient zur Kommunikation mit dem IMUNES HOST

vtnet1-3 kann für die Netzwerksimulation verwendet werden!

X Forwarding

unter Mac OS

  • 1. xquartz.macosforge.org installieren (für Yosemite 10.10+ die Beta nehmen)
  • 2. User einmal ausloggen und wieder anmelden
  • 3. X Forwarding
sudo -X root@.98
  • 4. als User im Terminal
echo $DISPLAY
  • 5. wieder im root SSH (remote) xterm / xfce4-session starten
[root@IMUNES ~]# xterm
[root@IMUNES ~]# xfce4-session
  • 6. IMUNES GUI starten

IMUNES Benutzung

Vorlage: /root/c3d2_daniel.imn

Screenshot

C3d2 imunes example.jpg

Hinweise

vlan scheint derzeit nicht zu gehen, die freenas bridge scheint es wohl nicht durchzureichen (müsste man mal genauer gebuggen)